Cisco Router DHCP Server Configuration

Network Layer 1 2 3

Goal

Setup DHCP server on router and verify setup using a client device.

DHCP server configuration :

Network 192.168.10.0/24

Domain name server 8.8.8.8 and 192.168.10.2

Default Gateway 192.168.10.1

and lease time 1 day

Exclude IP address 192.168.10.1 to 192.168.10.10

Topology 

DHCP_Server

DHCP Server Configuraion

ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool LAN_A_DHCP_SERVER
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8 192.168.10.2
domain-name Test-LAN
!

Applying DHCP server to interface

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!

Client Configuration 

Client#show running-config interface f0/0
Building configuration…

Current configuration : 75 bytes
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
end
Client#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.10.11 YES DHCP up up
Client#

Verify DHCP binding from Server 

DHCP-Server#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address                Client-ID/    …

View original post 53 mots de plus

Advertisements

Laisser un commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s